RFR: 8281314: Rename Stack{Red,Yellow,Reserved,Shadow}Pages multipliers [v2]
Thomas Stuefe
stuefe at openjdk.java.net
Mon Feb 7 16:05:14 UTC 2022
On Mon, 7 Feb 2022 15:55:47 GMT, Aleksey Shipilev <shade at openjdk.org> wrote:
>> This was a question during [JDK-8072070](https://bugs.openjdk.java.net/browse/JDK-8072070) review. The code in `StackOverflow::initialize_stack_zone_sizes()` multiplies `Stack{Red,Yellow,Reserved,Shadow}Pages` by "alignment", while that is actually just a "unit".
>>
>>
>> product_pd(intx, StackYellowPages, \
>> "Number of yellow zone (recoverable overflows) pages of size " \
>> "4KB. If pages are bigger yellow zone is aligned up.") \
>> range(MIN_STACK_YELLOW_PAGES, (DEFAULT_STACK_YELLOW_PAGES+5)) \
>>
>>
>> We can rename it for clarity.
>
> Aleksey Shipilev has updated the pull request incrementally with one additional commit since the last revision:
>
> Add comment blurb
LGTM
src/hotspot/share/runtime/stackOverflow.cpp line 44:
> 42: // We need to adapt the configured number of stack protection pages to the
> 43: // actual OS page size. We must do this before setting up minimal stack
> 44: // sizes etc. in os::init_2(). The option values are given in the 4K units,
s/in the 4K units/in 4K units
-------------
Marked as reviewed by stuefe (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/7362
More information about the hotspot-runtime-dev
mailing list