RFR: 8288497: add support for JavaThread::is_oop_safe() [v3]

Daniel D. Daugherty dcubed at openjdk.org
Tue Jun 21 16:09:44 UTC 2022


On Mon, 20 Jun 2022 01:46:03 GMT, David Holmes <dholmes at openjdk.org> wrote:

>> Daniel D. Daugherty has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Rename cannot_access_oops_safely to is_oop_safe and invert the function's logic.
>
> src/hotspot/share/runtime/thread.inline.hpp line 269:
> 
>> 267: }
>> 268: 
>> 269: inline bool JavaThread::is_oop_safe() const {
> 
> Do we want to document, and assert, that this is only intended for use by the current thread on itself? I can't imagine any scenario where we would need to ask whether an arbitrary thread is oop-safe. ??

@dholmes-ora - Thanks very much for the re-review.

I'll accept your "good as-is" and proceed with integration.

I think I've tweaked this fix enough at this point. Especially if we end up replacing
it with support in the GC subsystems instead.

-------------

PR: https://git.openjdk.org/jdk19/pull/20


More information about the hotspot-runtime-dev mailing list