RFR: 8287512: continuationEntry.hpp has incomplete definitions

Coleen Phillimore coleenp at openjdk.java.net
Tue May 31 11:52:42 UTC 2022


On Mon, 30 May 2022 12:42:55 GMT, Ron Pressler <rpressler at openjdk.org> wrote:

>> src/hotspot/share/runtime/continuationEntry.cpp line 38:
>> 
>>> 36: address ContinuationEntry::return_pc = nullptr;
>>> 37: 
>>> 38: void ContinuationEntry::set_enter_nmethod(CompiledMethod* cm) {
>> 
>> This looks weird. Do we really have `CompiledMethod*` arguments for this call? If so, it would be weird to call it `set_enter_*nmethod*`.
>
> `CompiledMethod` is all that's required here, and I also want to try calling that method from elsewhere (Method::set_code) where we only have `CompiledMethod`. But if it bothers anyone I can leave it an nmethod.

I agree, maybe rename to set_enter_method or set_enter_code() ?
Also the static data members don't have underscores, so I had to look to see what return_pc is, ie what this function did.  Was there a reason? If not, please add leading underscores to these nonstatic data members.

-------------

PR: https://git.openjdk.java.net/jdk/pull/8944


More information about the hotspot-runtime-dev mailing list