RFR: JDK-8312018: Improve reservation of class space and CDS [v8]

Andrew Dinn adinn at openjdk.org
Tue Aug 29 10:48:17 UTC 2023


On Tue, 29 Aug 2023 10:33:46 GMT, Andrew Dinn <adinn at openjdk.org> wrote:

>> Thomas Stuefe has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 14 commits:
>> 
>>  - merge
>>  - restrict 16-bit-move-optimized code path to platforms that benefit from it
>>  - Fix test bug on machines with >47 bit address space (ppcle and linux aarch64 /w 52 bit AS
>>  - Feedback Ioi
>>  - Roman: better comment in metaspaceShared
>>  - Changes to os::vm_min_addr
>>  - fix windows
>>  - added temporary logging for ppc
>>  - make API smaller for Ioi
>>  - factor out shuffle and hemi-split
>>  - ... and 4 more: https://git.openjdk.org/jdk/compare/3dc266c5...a213a375
>
> src/hotspot/share/memory/metaspace.cpp line 597:
> 
>> 595:   // the encoding base to zero anyway: the encoding base has to be the base of the mapped archive
>> 596:   // (ultimately, the start address of the region we are reserving here).
>> 597:   const bool try_in_low_address_ranges = !cds_runtime;
> 
> I think `try_in_low_address_range` would be a far better name for the method param than either the current `cds_runtime` or your original `strict_base`, following the principle that *it does what it says on the tin*.

Bike shedding done, you may stick with the current name if you wish.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/15041#discussion_r1308574702


More information about the hotspot-runtime-dev mailing list