RFR: 8278965: crash in SymbolTable::do_lookup

David Holmes dholmes at openjdk.org
Fri Feb 10 02:35:47 UTC 2023


On Thu, 9 Feb 2023 13:46:35 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:

> Please review this small change to hold the refcount of a super class name while calling handle_parallel_super_load. Contrary to what I wrote in JDK-8298061, the refcount in the Placeholder table should never go to one.  I can reproduce this with btree012 occasionally, so this fixes this too.
> 
> The include in placeholders.hpp is required to make the gtest compiled since placeholders header file has Symbol::maybe_increment_refcount and decrement calls.
> 
> Tested with the graal test that failed, and tier1-7.

Functional change seems fine. I can't say I can follow the test in detail.

Thanks.

test/hotspot/gtest/classfile/test_placeholders.cpp line 39:

> 37:   JavaThread* T2 = THREAD;
> 38:   // the thread should be in vm to use locks
> 39:   ThreadInVMfromNative ThreadInVMfromNative(THREAD);

Nit: The variable name would normally be a shorter acronym `tivmfn`.

-------------

Marked as reviewed by dholmes (Reviewer).

PR: https://git.openjdk.org/jdk/pull/12491


More information about the hotspot-runtime-dev mailing list