RFR: 8304147: JVM crash during shutdown when dumping dynamic archive [v2]
David Holmes
dholmes at openjdk.org
Mon Mar 27 05:01:30 UTC 2023
On Mon, 27 Mar 2023 04:53:29 GMT, David Holmes <dholmes at openjdk.org> wrote:
>> src/hotspot/share/cds/dynamicArchive.cpp line 385:
>>
>>> 383: HandleMark hm(current);
>>> 384:
>>> 385: if (!(DynamicDumpSharedSpaces && archive_name != nullptr)) {
>>
>> Can you make this !DynamicDumpSharedSpaces || archive_name == nullptr so it's easier to read. I'm trying to figure out how archive_name relates to ArchiveClassesAtExit and why you made the switch.
>
> I changed the condition to use a temp variable that should make things clearer.
>
> `ArchiveClassesAtExit` was always passed to `dump` as the `archive_name`, so no "switch" there.
Update: I changed the condition as you suggested.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/13134#discussion_r1148786154
More information about the hotspot-runtime-dev
mailing list