RFR: 8306738: Select num workers for safepoint ParallelCleanupTask [v3]
Coleen Phillimore
coleenp at openjdk.org
Thu May 4 18:50:18 UTC 2023
On Wed, 3 May 2023 14:34:16 GMT, Axel Boldt-Christmas <aboldtch at openjdk.org> wrote:
>> Select num workers for safepoint ParallelCleanupTask to be at most the number of parallel cleanup tasks `SAFEPOINT_CLEANUP_NUM_TASKS`
>>
>> Unsure if `WorkerThreads::max_workers()` is more correct than `WorkerThreads::created_workers()` or `WorkerThreads::active_workers()`.
>>
>> Tested tier1-3 Oracle platforms.
>
> Axel Boldt-Christmas has updated the pull request incrementally with one additional commit since the last revision:
>
> Add expected_num_workers
I think this looks fine from the symbol/string table perspective. This rehashing should never be done except in very exceptional circumstances.
> (Also the xxxTable code duplication is pretty atrocious)
Yes. It is.
src/hotspot/share/runtime/safepoint.cpp line 550:
> 548: Universe::heap()->uses_stack_watermark_barrier()) {}
> 549:
> 550: uint expected_num_workers() const {
should this be 'static' for internal linkage?
-------------
Marked as reviewed by coleenp (Reviewer).
PR Review: https://git.openjdk.org/jdk/pull/13616#pullrequestreview-1413715025
PR Review Comment: https://git.openjdk.org/jdk/pull/13616#discussion_r1185383741
More information about the hotspot-runtime-dev
mailing list