RFR: 8319048: Monitor deflation unlink phase prolongs time to safepoint [v7]

Stefan Karlsson stefank at openjdk.org
Mon Nov 20 13:20:36 UTC 2023


On Mon, 20 Nov 2023 11:02:10 GMT, Aleksey Shipilev <shade at openjdk.org> wrote:

> > 2. I find the names of the various monitors a bit non-descriptive and therefore it makes the code a bit harder to read. I experimented with these renames:
> >   
> > ```
> > m => batch_start
> > next => current
> > next_next => next
> > ```
> 
> It does not seem to work. `current` is already taken by thread. `m` is not always the batch start, it could also be the normal inflated monitor. `next_next` cannot be used without `next` rename.

I missed that we had `Thread* current` here. I still think we can have better names with a little bit of imagination. With that said, I think we should take Axel's PoC instead, so these names would be temporary anyway.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/16412#issuecomment-1819049039


More information about the hotspot-runtime-dev mailing list