RFR: 8320304: Refactor and simplify monitor deflation functions [v3]

David Holmes dholmes at openjdk.org
Tue Nov 21 00:35:09 UTC 2023


On Mon, 20 Nov 2023 22:58:41 GMT, Stefan Karlsson <stefank at openjdk.org> wrote:

>> src/hotspot/share/runtime/synchronizer.cpp line 1686:
>> 
>>> 1684: size_t ObjectSynchronizer::deflate_idle_monitors() {
>>> 1685:   JavaThread* current = JavaThread::current();
>>> 1686:   assert(current->is_monitor_deflation_thread(), "The only monitor deflater");
>> 
>> Given we know the thread that has to be involved here I'm wondering if we can couple the `MonitorDeflationThread` more tightly to this code in general. E.g. make this private and make the `MonitorDeflationThread` class a friend. Store the instance and have an accessor like we do for VMThread and avoid any need to materialize `JavaThread::current()`? You could even move the MDT code into a nested class to show the tight coupling.
>
> Maybe. I think someone needs to try it out to see if the code becomes nicer with that.

I'll file a RFE to have that looked at.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/16706#discussion_r1399896694


More information about the hotspot-runtime-dev mailing list