RFR: 8261837: SIGSEGV in ciVirtualCallTypeData::translate_from [v2]
Dean Long
dlong at openjdk.org
Wed Nov 22 00:52:22 UTC 2023
On Wed, 22 Nov 2023 00:09:58 GMT, Vladimir Ivanov <vlivanov at openjdk.org> wrote:
>> src/hotspot/cpu/x86/c1_LIRAssembler_x86.cpp line 3634:
>>
>>> 3632: #ifdef ASSERT
>>> 3633: if (obj == tmp) {
>>> 3634: LP64_ONLY(assert_different_registers(obj, rscratch1, mdo_addr.base(), mdo_addr.index());)
>>
>> I find `#ifdef _LP64` more readable than `LP64_ONLY`/`NOT_LP64` here.
>
> Moreover, any particular problems with unconditionally passing `rscratch1`? `rscratch1` is set to`noreg` on x86_32 and I believe `assert_different_registers` should handle it well if all other arguments are guaranteed to be valid registers.
mdo_addr.index() can be noreg.
I used LP64_ONLY/NOT_LP64 because it was more compact, but I'm OK with #ifdef too.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/16750#discussion_r1401375662
More information about the hotspot-runtime-dev
mailing list