RFR: 8302744: Refactor Hotspot container detection code [v2]

Severin Gehwolf sgehwolf at openjdk.org
Tue May 21 13:58:22 UTC 2024


> Please review this container detection code refactoring in hotspot. The main point of this is to
> 
> - get rid of the `GET_CONTAINER_INFO` macros which hide too many things under the hood
> - prevent refactoring of the code (since `GET_CONTAINER_INFO` macros short-return and are therefore not portable; at least not without some risk)
> - make the code easier to understand
> - allow for better testing via `gtest`
> - separate multi-line parsing from single line parsing for clarity.
> 
> Testing:
> - [x] GHA
> - [x] `gtest:cgroupTest` tests
> - [x] Container tests on Linux with cgroup v1 (legacy) and cgroup v2. All pass.
> 
> Thoughts?

Severin Gehwolf has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains ten additional commits since the last revision:

 - Fix TestMemoryAwareness for cgroup v2
   
   It only reads the swap value, thus doesn't print:
   "Memory and Swap Limit is" but rather prints:
   "Swap Limit is". This is fine, since for cg v2
   the memory limit and the swap limits are in different
   files.
 - Fix whitespace
 - Handle cpu quota for cgroups v1 specially
 - Try a different approach.
   
   Hybrid MACRO usage and locked down reading primitives.
 - Add key-value read function
 - Add basic testing for read functions
 - Add generic julong/char* read functions
 - Merge branch 'master' into jdk-8302744-cleanup-getcontainer-info
 - 8302744: Refactor Hotspot container detection code

-------------

Changes:
  - all: https://git.openjdk.org/jdk/pull/19060/files
  - new: https://git.openjdk.org/jdk/pull/19060/files/eda2aa97..9ac1b407

Webrevs:
 - full: https://webrevs.openjdk.org/?repo=jdk&pr=19060&range=01
 - incr: https://webrevs.openjdk.org/?repo=jdk&pr=19060&range=00-01

  Stats: 29002 lines in 737 files changed: 15580 ins; 8231 del; 5191 mod
  Patch: https://git.openjdk.org/jdk/pull/19060.diff
  Fetch: git fetch https://git.openjdk.org/jdk.git pull/19060/head:pull/19060

PR: https://git.openjdk.org/jdk/pull/19060


More information about the hotspot-runtime-dev mailing list