RFR: 8302744: Refactor Hotspot container detection code [v4]
Severin Gehwolf
sgehwolf at openjdk.org
Mon May 27 19:54:16 UTC 2024
> Please review this container detection code refactoring in hotspot. The main point of this is to
>
> - get rid of the `GET_CONTAINER_INFO` macros which hide too many things under the hood
> - prevent refactoring of the code (since `GET_CONTAINER_INFO` macros short-return and are therefore not portable; at least not without some risk)
> - make the code easier to understand
> - allow for better testing via `gtest`
> - separate multi-line parsing from single line parsing for clarity.
>
> Testing:
> - [x] GHA
> - [x] `gtest:cgroupTest` tests
> - [x] Container tests on Linux with cgroup v1 (legacy) and cgroup v2. All pass.
>
> Thoughts?
Severin Gehwolf has updated the pull request incrementally with four additional commits since the last revision:
- Make read_string() take the output buffer size
- Fix style for read_numerical_key_value
- Use assertions for required parameters
- Use boolean for tuples
-------------
Changes:
- all: https://git.openjdk.org/jdk/pull/19060/files
- new: https://git.openjdk.org/jdk/pull/19060/files/c41d3183..e41b5f6b
Webrevs:
- full: https://webrevs.openjdk.org/?repo=jdk&pr=19060&range=03
- incr: https://webrevs.openjdk.org/?repo=jdk&pr=19060&range=02-03
Stats: 128 lines in 5 files changed: 23 ins; 48 del; 57 mod
Patch: https://git.openjdk.org/jdk/pull/19060.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/19060/head:pull/19060
PR: https://git.openjdk.org/jdk/pull/19060
More information about the hotspot-runtime-dev
mailing list