RFR: 8302744: Refactor Hotspot container detection code [v5]
Severin Gehwolf
sgehwolf at openjdk.org
Tue May 28 12:51:20 UTC 2024
> Please review this container detection code refactoring in hotspot. The main point of this is to
>
> - get rid of the `GET_CONTAINER_INFO` macros which hide too many things under the hood
> - prevent refactoring of the code (since `GET_CONTAINER_INFO` macros short-return and are therefore not portable; at least not without some risk)
> - make the code easier to understand
> - allow for better testing via `gtest`
> - separate multi-line parsing from single line parsing for clarity.
>
> Testing:
> - [x] GHA
> - [x] `gtest:cgroupTest` tests
> - [x] Container tests on Linux with cgroup v1 (legacy) and cgroup v2. All pass.
>
> Thoughts?
Severin Gehwolf has updated the pull request incrementally with one additional commit since the last revision:
Review feedback for the test
-------------
Changes:
- all: https://git.openjdk.org/jdk/pull/19060/files
- new: https://git.openjdk.org/jdk/pull/19060/files/e41b5f6b..575935f4
Webrevs:
- full: https://webrevs.openjdk.org/?repo=jdk&pr=19060&range=04
- incr: https://webrevs.openjdk.org/?repo=jdk&pr=19060&range=03-04
Stats: 61 lines in 2 files changed: 14 ins; 4 del; 43 mod
Patch: https://git.openjdk.org/jdk/pull/19060.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/19060/head:pull/19060
PR: https://git.openjdk.org/jdk/pull/19060
More information about the hotspot-runtime-dev
mailing list