Integrated: 8302744: Refactor Hotspot container detection code

Severin Gehwolf sgehwolf at openjdk.org
Wed May 29 08:50:15 UTC 2024


On Thu, 2 May 2024 12:36:11 GMT, Severin Gehwolf <sgehwolf at openjdk.org> wrote:

> Please review this container detection code refactoring in hotspot. The main point of this is to
> 
> - get rid of the `GET_CONTAINER_INFO` macros which hide too many things under the hood
> - prevent refactoring of the code (since `GET_CONTAINER_INFO` macros short-return and are therefore not portable; at least not without some risk)
> - make the code easier to understand
> - allow for better testing via `gtest`
> - separate multi-line parsing from single line parsing for clarity.
> 
> Testing:
> - [x] GHA
> - [x] `gtest:cgroupTest` tests
> - [x] Container tests on Linux with cgroup v1 (legacy) and cgroup v2. All pass.
> 
> Thoughts?

This pull request has now been integrated.

Changeset: 3d4eb159
Author:    Severin Gehwolf <sgehwolf at openjdk.org>
URL:       https://git.openjdk.org/jdk/commit/3d4eb159e6d597f37081faf21b7e3f0f1af299e5
Stats:     1294 lines in 10 files changed: 705 ins; 433 del; 156 mod

8302744: Refactor Hotspot container detection code

Reviewed-by: jsjolen, stuefe

-------------

PR: https://git.openjdk.org/jdk/pull/19060


More information about the hotspot-runtime-dev mailing list