RFR: 8341334: CDS: Parallel pretouch and relocation [v7]

Aleksey Shipilev shade at openjdk.org
Wed Nov 6 09:22:32 UTC 2024


On Wed, 6 Nov 2024 06:09:55 GMT, Ioi Lam <iklam at openjdk.org> wrote:

>> Aleksey Shipilev has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains 13 additional commits since the last revision:
>> 
>>  - More perf touchups
>>  - Cap the max number of workers
>>  - Revert pre-touch parts: there are startup regressions on smaller thread counts
>>  - Handle single-threaded modes better
>>  - Merge branch 'master' into JDK-8341334-cds-parallel-relocation
>>  - Merge branch 'master' into JDK-8341334-cds-parallel-relocation
>>  - Make sure we gracefully shutdown whatever happens, refix shutdown race
>>  - Simpler bitmap distribution
>>  - Capitalize constants
>>  - Do not create worker threads too early: Mac/Windows are not yet ready to use Semaphores
>>  - ... and 3 more: https://git.openjdk.org/jdk/compare/e5593464...d4d739b1
>
> src/hotspot/share/cds/cds_globals.hpp line 99:
> 
>> 97:                                                                             \
>> 98:   product(bool, ArchiveParallelRelocation, true, DIAGNOSTIC,                \
>> 99:           "Use parallel relocation code to speed up startup.")              \
> 
> Maybe wait after JEP 483 integration and rename this flag to `AOTCacheParallelRelocation` to be consistent with the new naming scheme?

Yeah, we can do that. Actually, I will rename the flag right now.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/21302#discussion_r1830651198


More information about the hotspot-runtime-dev mailing list