RFR: 8341094: Clean up relax_verify in ClassFileParser [v2]
Coleen Phillimore
coleenp at openjdk.org
Fri Nov 8 12:18:59 UTC 2024
On Thu, 7 Nov 2024 23:03:26 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:
>> Removed ClassFileParser::_relax_verify and cleaned up setting need_verify in the ClassFileStream code and ClassFileParser. Wrote up how I found control to flow to this setting with -Xverify:all/none/remote settings, which become BytecodeVerificationRemote/Local in the CR comments.
>>
>> Tested with tier1-4. Valid class, field and method name testing is done through the JCK and there are CDS tests that test verification in runtime/cds/appcds/VerifierTest.java.
>
> Coleen Phillimore has updated the pull request incrementally with one additional commit since the last revision:
>
> Rename ClassFileStream::_need_verify to _check_truncation and set based on one call in ClassFileParser.
Ioi, your suggestion of passing class_loader to stream creation is really a cumbersome change. The Stream's version of need_verify is an internal flag used for determining whether we need to check for truncation and should be based on the ClassFileParser's call when we're about to parse the stream. But I did some cleanup to further unexpose this field.
-------------
PR Comment: https://git.openjdk.org/jdk/pull/21954#issuecomment-2464607153
More information about the hotspot-runtime-dev
mailing list