RFR: 8350313: Include timings for leaving safepoint in safepoint logging [v3]

Xiaolong Peng xpeng at openjdk.org
Tue Feb 25 17:06:04 UTC 2025


On Tue, 25 Feb 2025 08:52:43 GMT, Aleksey Shipilev <shade at openjdk.org> wrote:

>> Xiaolong Peng has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Renames
>
> src/hotspot/share/runtime/safepoint.cpp line 870:
> 
>> 868: jlong SafepointTracing::_last_safepoint_begin_time_ns = 0;
>> 869: jlong SafepointTracing::_last_safepoint_sync_time_ns = 0;
>> 870: jlong SafepointTracing::_last_vmop_evaluation_end_time_ns = 0;
> 
> From the adjacent names, I think it should be `_last_safepoint_leave_time_ns`.

Thanks, I have updated the names.

> src/hotspot/share/runtime/safepoint.hpp line 255:
> 
>> 253:   static void begin(VM_Operation::VMOp_Type type);
>> 254:   static void synchronized(int nof_threads, int nof_running, int traps);
>> 255:   static void end_vmop_evaluation();
> 
> I think of a little better name: `leave()`?

Thanks, updated.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/23756#discussion_r1970198067
PR Review Comment: https://git.openjdk.org/jdk/pull/23756#discussion_r1970198366


More information about the hotspot-runtime-dev mailing list