RFR: 8351046: Rename ObjectMonitor functions

Coleen Phillimore coleenp at openjdk.org
Fri Mar 7 18:44:26 UTC 2025


On Tue, 4 Feb 2025 22:05:59 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:

> This change simply changes the remaining names of functions in objectMonitor that were camel case, now following the hotspot coding standard.  Recent changes have been confused about which style to use, so this helps with this.  This is a mechanical change, largely trivial.  Further improvements can be different PRs, but any names missed could be added to this.
> Ran tier1 on Oracle standard platforms.

#!/bin/csh -f
cd runtime
foreach f (objectMonitor.hpp objectMonitor.inline.hpp objectMonitor.cpp)
  sed -e "s/AddWaiter/add_waiter/g" \
      -e "s/INotify/notify_internal/g" \
      -e "s/DequeueWaiter/dequeue_waiter/g" \
      -e "s/DequeueSpecificWaiter/dequeue_specific_waiter/g" \
      -e "s/EnterI/enter_internal/g" \
      -e "s/ReenterI/reenter_internal/g" \
      -e "s/UnlinkAfterAcquire/unlink_after_acquire/g" \
      -e "s/ExitEpilog/exit_epilog/g" \
      -e "s/VThreadMonitorEnter/vthread_monitor_enter/g" \
      -e "s/VThreadWait/vthread_wait/g" \
      -e "s/VThreadWaitReenter/vthread_wait_reenter/g" \
      -e "s/TryWithContentionMark/try_with_contention_mark/g" \
      -e "s/TryLock(/try_lock(/g" \
      -e "s/TrySpin/try_spin/g" \
      -e "s/VThreadEpilog/vthread_epilog/g"  $f > $f.new
  diff $f.new $f
  mv $f.new $f
end

-------------

PR Comment: https://git.openjdk.org/jdk/pull/23450#issuecomment-2636854789


More information about the hotspot-runtime-dev mailing list