RFR: 8351046: Rename ObjectMonitor functions [v2]

Stefan Karlsson stefank at openjdk.org
Mon Mar 10 07:13:56 UTC 2025


On Fri, 7 Mar 2025 18:50:36 GMT, Coleen Phillimore <coleenp at openjdk.org> wrote:

>> This change simply changes the remaining names of functions in objectMonitor that were camel case, now following the hotspot coding standard.  Recent changes have been confused about which style to use, so this helps with this.  This is a mechanical change, largely trivial.  Further improvements can be different PRs, but any names missed could be added to this.
>> Ran tier1 on Oracle standard platforms.
>
> Coleen Phillimore has updated the pull request incrementally with one additional commit since the last revision:
> 
>   Typo in sed script.

Nice cleanup. Maybe one nit:

src/hotspot/share/runtime/objectMonitor.cpp line 1191:

> 1189: 
> 1190:   if (node->is_wait() && !node->at_reenter()) {
> 1191:     bool acquired_monitor = vthread_waitReenter(current, node, cont);

Should this be vthread_wait_reenter?

-------------

Marked as reviewed by stefank (Reviewer).

PR Review: https://git.openjdk.org/jdk/pull/23450#pullrequestreview-2669972619
PR Review Comment: https://git.openjdk.org/jdk/pull/23450#discussion_r1986717980


More information about the hotspot-runtime-dev mailing list