<i18n dev> [9] RFR: 8061382: Separate CLDR locale data from JRE locale data

Naoto Sato naoto.sato at oracle.com
Thu Oct 23 16:07:40 UTC 2014

Thanks for the naming suggestion, Alan. I will use "classic" then.

I also think we should introduce "CLASSIC" as a property name for the 
java.locale.providers system property which should be an alias to "JRE", 
this requires a CCC though.


On 10/23/14, 6:55 AM, Alan Bateman wrote:
> On 23/10/2014 09:17, Masayoshi Okutsu wrote:
>> On 10/23/2014 4:58 PM, Alan Bateman wrote:
>>> jdk.localedata.XXX looks right. I wonder if we can find something
>>> better than "jre" for the suffix of the first one. I ask because
>>> linking that into a runtime that isn't the what we know today as the
>>> JRE might be confusing.
>> Actually Naoto and I discussed that issue, but we couldn't come up
>> with any better one. Any suggestions?
> I agree that finding a good name is hard. As we talking about service
> provider modules then the naming is slightly less important than for
> modules that export APIs but still important to find a good name. I
> don't know if you have considered jdk.localedata.classic and
> jdk.localedata.cldr.
> -Alan

More information about the i18n-dev mailing list