<i18n dev> [9] RFR: 8074350/8074351
Naoto Sato
naoto.sato at oracle.com
Tue Mar 17 20:10:21 UTC 2015
Thanks. I modified the change based on your suggestion:
http://cr.openjdk.java.net/~naoto/8074350.8074351/webrev.01/
Naoto
On 3/17/15 12:57 AM, Masayoshi Okutsu wrote:
> Here are my comments.
>
> - Are there any reasons that the bit fields can't be relocated? Since
> the format version is changed, it should be OK to use contiguous 4 bits
> for fraction digits?
>
> - Use of these magic numbers should be avoided.
>
> make/src/classes/build/tools/generatecurrencydata/GenerateCurrencyData.java
> + private static String[] currenciesWithDefinedMinorUnitDecimals =
> new String[10];
> + for (int i = 0; i <= 9; i++) {
> src/java.base/share/classes/java/util/Currency.java
> + if (fraction > 9) {
> test/java/util/Currency/PropertiesTest.java
> + if (fraction > 9) {
>
> Otherwise, the changes look good to me.
>
> Masayoshi
>
> On 3/12/2015 7:25 AM, Naoto Sato wrote:
>> Hello,
>>
>> Please review the following two enhancements in java.util.Currency class:
>>
>> 8074350: Support ISO 4217 "Current funds codes" table (A.2) [1]
>> 8074351: Support for currencies with the 4 digits (or more) minor unit
>> [2]
>>
>> The proposed change is located at:
>>
>> http://cr.openjdk.java.net/~naoto/8074350.8074351/webrev.00/
>>
>> Naoto
>>
>> [1] https://bugs.openjdk.java.net/browse/JDK-8074350
>> [2] https://bugs.openjdk.java.net/browse/JDK-8074351
>
More information about the i18n-dev
mailing list