<i18n dev> Integrated: 8275106: Cleanup Iterator usages in java.desktop

Andrey Turbanov duke at openjdk.java.net
Fri Oct 15 07:12:51 UTC 2021

On Fri, 8 Oct 2021 19:37:35 GMT, Andrey Turbanov <duke at openjdk.java.net> wrote:

> Cycles with 'Iterator' are error-prone. It's better to use more high-level code, which easier to read.
> We can use enhanced-for or Collection.removeIf

This pull request has now been integrated.

Changeset: 322b1301
Author:    Andrey Turbanov <turbanoff at gmail.com>
Committer: Pankaj Bansal <pbansal at openjdk.org>
URL:       https://git.openjdk.java.net/jdk/commit/322b1301061ba113dc5f7f3710dde2d80a18a14e
Stats:     115 lines in 18 files changed: 5 ins; 62 del; 48 mod

8275106: Cleanup Iterator usages in java.desktop

Reviewed-by: serb, pbansal


PR: https://git.openjdk.java.net/jdk/pull/5871

More information about the i18n-dev mailing list