<i18n dev> RFR: 8316557: Make fields final in 'sun.util' package [v2]

Naoto Sato naoto at openjdk.org
Fri Nov 17 18:07:32 UTC 2023


On Fri, 17 Nov 2023 08:38:37 GMT, Andrey Turbanov <aturbanov at openjdk.org> wrote:

>> The map contains several entries so I think the plural form is appropriate here.
>
> Current naming highlights the difference in values in this maps: `FIRST_DAY_OF_WEEK` vs `MINIMAL_DAYS_IN_FIRST_WEEK`.
> I like this approach.

Maybe `firstDayMap`/`minDaysMap` would clarify more, but either way is fine with me

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/15736#discussion_r1397697691


More information about the i18n-dev mailing list