<i18n dev> RFR: 8342863: Use pattern matching for instanceof in equals methods of wrapper classes
Joe Darcy
darcy at openjdk.org
Wed Oct 23 15:40:08 UTC 2024
On Wed, 23 Oct 2024 05:45:33 GMT, Rémi Forax <forax at openjdk.org> wrote:
>> Noticed this refactoring opportunity while doing some other work in the area.
>
> src/java.base/share/classes/java/lang/Boolean.java line 259:
>
>> 257: public boolean equals(Object obj) {
>> 258: if (obj instanceof Boolean b) {
>> 259: return value == b.booleanValue();
>
> I would go even a step further and use `value` instead of `booleanValue()`, `intValue()` etc because there is no need to call a method to get the value.
>
>
> if (obj instanceof Boolean b) {
> return value == b.value;
Hi @forax,
Yes, I had considered that before sending out the PR. It shouldn't matter from a performance perspective, so it would come to down to which version of the code was marginally easier to read.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/21652#discussion_r1813056177
More information about the i18n-dev
mailing list