RFR: 8273544: Increase test coverage for snippets [v2]

Jonathan Gibbons jjg at openjdk.java.net
Thu Nov 18 18:32:51 UTC 2021


On Thu, 18 Nov 2021 14:58:52 GMT, Pavel Rappo <prappo at openjdk.org> wrote:

>>> I assume the purpose of this naming scheme is to make visible what combinations of features are covered by each test. I'm not sure I would consider this enough benefit to justify method names which are very verbose and hard to read (especially when you don't have fresh memory of the scheme above).
>> 
>> You are right when saying that this naming scheme helps to survey the test landscape. This is especially helpful while mass-developing tests, which is what I'm doing at the moment.
>
> Do you think we could add an underscore here and there to improve readability? For example, we could separate the first four parts of the name from the last part, which is a custom string:
> 
> testNegativeExternalTag_FileNotFoundModuleSourcePath
> 
> I'm not against "camelCase", but I have to admit that "snake_case" or a reasonable mix of both styles might work better for longer names.

In general, given the size of the file, I like the verbose names, if only because it gives the reader a strong hint up front about the form (nature) of the test.

That being said, now that you have introduced `SnippetTester` (which is great!) you could split this file. I would definitely group positive and negative test cases in the same file, but you could maybe separate `Tag` and `Markup` tests into separate files. (Just a suggestion).   

FWIW, my experience is that it is easier to test/debug files with fewer methods in, although it is on my to-do list to make it easier to run individual test cases.

-------------

PR: https://git.openjdk.java.net/jdk/pull/6359


More information about the javadoc-dev mailing list