RFR: 8283269: Improve definition and use of jdk.javadoc.internal.doclets.toolkit.Content [v2]

Pavel Rappo prappo at openjdk.java.net
Mon Mar 28 10:57:31 UTC 2022


On Fri, 25 Mar 2022 17:29:45 GMT, Jonathan Gibbons <jjg at openjdk.org> wrote:

>> Pavel Rappo has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   Address (some) feedback
>
> src/jdk.javadoc/share/classes/jdk/javadoc/internal/doclets/formats/html/AbstractMemberWriter.java line 190:
> 
>> 188:      * @param target the content to which the modifiers and type will be added
>> 189:      */
>> 190:     protected void addModifierAndType(Element member, TypeMirror type,
> 
> For later: maybe adjust method name as well

Done.

> why not `var`?

Why? Because it had neither "trees" nor "contents" around, hence was out of scope. That said, I fixed it.

> src/jdk.javadoc/share/classes/jdk/javadoc/internal/doclets/formats/html/ConstantsSummaryWriterImpl.java line 71:
> 
>> 69: 
>> 70:     /**
>> 71:      * The HTML node for constant values summary currently being written.
> 
> This change seems unnecessary and just in produces an unnecessary synonym

Reverted.

> src/jdk.javadoc/share/classes/jdk/javadoc/internal/doclets/formats/html/Signatures.java line 415:
> 
>> 413:          * Set the parameter information of an executable member.
>> 414:          *
>> 415:          * @param content the parameter information.
> 
> maybe a general cleanup later on fixing trailing periods?

Yes; as I've already said, superfluous periods and "3rd person declarative" for opening verbs warrant a separate PR.

> why is the comment significant?

I'll remove it. It's a leftover from my attempt to prove to myself that this method does not have side effects and, therefore, warrants use of a non-specific word like "get" or "return". Generally, this concern should be addressed in a follow-up refactoring effort.

-------------

PR: https://git.openjdk.java.net/jdk/pull/7843


More information about the javadoc-dev mailing list