RFR: JDK-8286153: Remove redundant casts and other cleanup

Jonathan Gibbons jjg at openjdk.java.net
Thu May 5 14:43:15 UTC 2022


On Thu, 5 May 2022 09:58:13 GMT, Pavel Rappo <prappo at openjdk.org> wrote:

>> Please review some cleanup updates to address issues reported by an IDE.
>> 
>> The seeds for the change were a series of redundant casts, that have now all been removed.  Various other warnings and suggestions were made by the IDE for the affected files. There were a number of places with redundant type arguments, for which the general fix was in favor of using `var` instead of `<>`.
>> 
>> Some `switch` statements were converted to the enhanced `switch` form, which also revealed a couple of places where `RECORD` should have been added alongside `ENUM`.
>
> src/jdk.javadoc/share/classes/jdk/javadoc/internal/doclets/formats/html/HtmlDocletWriter.java line 297:
> 
>> 295:         VisibleMemberTable vmt = configuration.getVisibleMemberTable(enclosing);
>> 296:         // Check whether there is any implementation or overridden info to be
>> 297:         // printed. If not overridden or implementation info needs to be
> 
> Although awkward, it was correct before the change. Consider rewriting for clarity or deleting it. The code is pretty self-descriptive, if you ask me.

ooops, will fix.

> src/jdk.javadoc/share/classes/jdk/javadoc/internal/doclets/toolkit/util/MetaKeywords.java line 81:
> 
>> 79:             results.addAll(getMemberKeywords(utils.getMethods(typeElement)));
>> 80:         }
>> 81:         results.trimToSize();
> 
> I wonder if this method will look better this way:
> 
>     public List<String> getMetaKeywords(TypeElement typeElement) {
>         var results = new ArrayList<String>();
>         ...
>         results.trimToSize();
>         return results;
>     }

Agreed; I was just trying to limit the cleanup. `var` is good.

> src/jdk.javadoc/share/classes/jdk/javadoc/internal/doclets/toolkit/util/MetaKeywords.java line 156:
> 
>> 154:             }
>> 155:         }
>> 156:         results.trimToSize();
> 
> Same suggestion for `var` as above.

��

-------------

PR: https://git.openjdk.java.net/jdk/pull/8543


More information about the javadoc-dev mailing list