RFR: 8300517: Refactor VisibleMemberTable (method members) [v2]
Pavel Rappo
prappo at openjdk.org
Fri Mar 10 16:19:15 UTC 2023
On Thu, 9 Mar 2023 20:03:04 GMT, Jonathan Gibbons <jjg at openjdk.org> wrote:
>> Pavel Rappo has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Respond to feedback
>
> src/jdk.javadoc/share/classes/jdk/javadoc/internal/doclets/toolkit/util/VisibleMemberTable.java line 637:
>
>> 635: }
>> 636:
>> 637: private static <K, V> boolean putAllIsNonReplacing(Map<K, V> dst, Map<K, V> src) {
>
> naming suggestion: the dominant initial word here is `put` but the method is a predicate, suggesting that the initial word should be `is`. ... and/or maybe up-level the name to be less implementation-specific (i.e. the `nonReplacing` bit)
Readability, sigh. That method was created only to be used in an assertion. The sole call site was supposed to be read like this: "assert _that_ putAll Is non-replacing", or some such.
-------------
PR: https://git.openjdk.org/jdk/pull/12887
More information about the javadoc-dev
mailing list