Introducing time wasters
talden at gmail.com
Sat Sep 22 01:53:58 UTC 2018
I like the 'maintainer' suggestion - dev is a little 'down in the code',
whereas maintainer recognises all of the contributors of assets to the
I wouldn't use 'sink' myself because this reads negatively and feels odd
when placed on tooling enhancements.
To me 'maintainer-productivity' would read more neutrally (though long) and
simply states the benefit of resolving the issue - though I'm aware that
this thread started with a desire to draw attention to pain (rather than
On Sat, Sep 22, 2018 at 12:23 PM <mark.reinhold at oracle.com> wrote:
> 2018/9/21 12:03:03 -0700, daniel.daugherty at oracle.com:
> > Rather than make it specific to 'dev' or 'developers', perhaps
> > productivity-sink
> Productivity sink for whom? Someone using the JDK, or someone working
> on it? Arguably the lack of (to pick a random example) extension
> methods in the language is a productivity sink for some developers in
> the latter category.
> This suggests labels that include the token “maintainer.” Maybe one of:
> ... or something like that.
> - Mark
More information about the jdk-dev