Java API Improvements
netbeans at post.cz
netbeans at post.cz
Fri Apr 17 06:24:23 UTC 2020
In context:
https://mail.openjdk.java.net/pipermail/jdk-dev/2020-April/004240.html
Improvement String:
Instead of:
public static boolean isNotNullAndBlank(String value)
public static boolean isNotNullAndEmpty(String value)
in case of adding "unless" (Stream; see link above):
public static boolean isNullOrBlank(String value)
public static boolean isNullOrEmpty(String value)
Improvement CharSequence: //if below ones are added then isNullOrBlank and
isNullOrEmpty could goes there
public default isEmpty();
public default isBlank();
More information about the jdk-dev
mailing list