A static null-coalescing method
Roger Riggs
roger.riggs at oracle.com
Mon Oct 28 20:34:09 UTC 2024
Hi,
I guess I'd stop slacking off and figure out where that method goes.
It's not clear it belongs on Optional, since it doesn't produce or
consume an Optional.
java.util.Objects is seems better as long as it can be named to avoid
any confusion with other methods.
:) Roger
On 10/28/24 4:20 PM, Roger Riggs wrote:
> Hi,
>
> I think that's covered by the instance method `Optional.orElse(def)`
>
> Regards, Roger
>
> [1]
> https://docs.oracle.com/en/java/javase/23/docs/api/java.base/java/util/Optional.html#orElse(T)
>
>
>
> On 10/28/24 3:40 PM, Emre Kaplan wrote:
>> Hello,
>>
>> I think java.util.Optional class should have a static method named like
>> getOrDefault(Object o, Object default)
>>
>> In short, if an object is null, it should return the default object,
>> otherwise the same object. And inside, default null check should be
>> done. Same result can be achieved by method chaining of ofNullable
>> and orElse, but then an object is created. I think it will be memory
>> efficient because only one static method needs to be called. I don't
>> know if it has been discussed before.
>>
>> Also there is Objects.requireNonNullElse(Object o1, Object o2)
>> but the second parameter should be non-null.
>>
>> Thanks in advance..
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.org/pipermail/jdk-dev/attachments/20241028/a30cc475/attachment-0001.htm>
More information about the jdk-dev
mailing list