hg: jdk/sandbox: 8189140: SystemDictionaryShared::initialize() should be renamed to be more meaningful

chris.hegarty at oracle.com chris.hegarty at oracle.com
Wed May 16 19:00:22 UTC 2018


Changeset: b5023063346d
Author:    iklam
Date:      2018-05-15 14:49 -0700
URL:       http://hg.openjdk.java.net/jdk/sandbox/rev/b5023063346d

8189140: SystemDictionaryShared::initialize() should be renamed to be more meaningful
Summary: Removed this function, added JavaCalls::construct_new_instance and moved SharedDictionary_lock
Reviewed-by: jiangli, ccheung, dholmes, coleenp

! src/hotspot/share/classfile/systemDictionary.cpp
! src/hotspot/share/classfile/systemDictionary.hpp
! src/hotspot/share/classfile/systemDictionaryShared.cpp
! src/hotspot/share/classfile/systemDictionaryShared.hpp
! src/hotspot/share/runtime/javaCalls.cpp
! src/hotspot/share/runtime/javaCalls.hpp
! src/hotspot/share/runtime/mutexLocker.cpp
! src/hotspot/share/runtime/mutexLocker.hpp



More information about the jdk-sandbox-changes mailing list