[jdk11u-dev] RFR: 8234930: Use MAP_JIT when allocating pages for code cache on macOS [v6]

Thomas Stuefe stuefe at openjdk.java.net
Thu Dec 9 13:29:05 UTC 2021


On Thu, 9 Dec 2021 12:23:34 GMT, Vladimir Kempik <vkempik at openjdk.org> wrote:

>> Hello, here is alternative backport of 8234930 to jdk11u.
>> Very minimalistic change for platforms other than macos, just one unused argument.
>> We have used this patch in zulu11 for more than a year now and found no issues with it on macos and other platforms.
>>
>> Technically it's mostly the same as previous (3patch) version but has no prerequests.
>
> Vladimir Kempik has updated the pull request incrementally with one additional commit since the last revision:
>
>   Add a comment into os_bsd

Hi Vladimir,

I am fine with this. I'll give this version a spin in our tests tonight.

The MACOS_ONLY issue is weird though since we use _ONLY macros in a similar way in a number of places. Ah well.

The rest of the remarks is plain nitpicking. Feel free to follow or ignore them.

Thanks for this, this is way easier to manage than a string of large patches.

Cheers, Thomas

src/hotspot/os/bsd/os_bsd.cpp line 2194:

> 2192:                             size_t alignment_hint) {
> 2193:   return anon_mmap(requested_addr, bytes, (requested_addr != NULL));
> 2194: })

Nitpicking and a matter of taste, but for multiline diffs I find #ifdef __APPLE__ easier to read.

-------------

Marked as reviewed by stuefe (Reviewer).

PR: https://git.openjdk.java.net/jdk11u-dev/pull/710



More information about the jdk-updates-dev mailing list