RFR 7902099: Add JemmySWT to jemmy/v3

Erik Greijus erik.greijus at oracle.com
Fri Jan 19 08:27:23 UTC 2018


I still do think that the variable name below should be renamed to at least not be related to "Composite" as that's not what it is about and might create confusion.

CompositeWrap.java:
120                             Widget childComposite = Widget.class.cast(child);
121                             if (!childComposite.isDisposed()) {
-rename variable "childComposite" -> "childWidget"?

Other than that I'm OK with the rest of it.
/Erik


> 18 jan. 2018 kl. 20:06 skrev Alexandre (Shura) Iline <alexandre.iline at oracle.com>:
> 
> I went through the code and did put final, where it is applicable and cleared some of other things you mention below.
> 
> The rest of your comments are not affecting behavior and could be done with later. Please take anther look:
> 
> http://cr.openjdk.java.net/~shurailine/7902099/webrev.01/
> 
> Shura
> 
> 
>> On Jan 18, 2018, at 1:47 AM, Erik Greijus <erik.greijus at oracle.com> wrote:
>> 
>> Hello,
>> KeyboardSelector.java:
>> 37     private Wrap<?> wrap;
>> 38     private KeyboardSelectable<T> control;
>> -both can be final
>> 
>> Browser.java:
>> -really keep the commented code?:
>> 79                                 /*
>> 80                                 if (subParent instanceof Table) {
>> 81                                 setResult(((Table) subParent).getItems());
>> 82                                 } else if (subParent instanceof ToolBar) {
>> 83                                 setResult(((ToolBar) subParent).getItems());
>> 84                                 } else if (subParent instanceof TabFolder) {
>> 85                                 setResult(((TabFolder) subParent).getItems());
>> 86                                 } else {
>> 87                                 setResult(new Object[0]);
>> 88                                 }
>> 89                                 if (subParent instanceof Composite) {
>> 90                                 Object[] oldResult = getResult();
>> 91                                 Object[] children = ((Composite)subParent).getChildren();
>> 92                                 Object[] newResult = new Object[oldResult.length + children.length];
>> 93                                 System.arraycopy(oldResult, 0, newResult, 0, oldResult.length);
>> 94                                 System.arraycopy(children, 0, newResult, oldResult.length, children.length);
>> 95                                 setResult(newResult);
>> 96                                 }
>> 97                                  *
>> 98                                  */
>> 
>> CompositeWrap.java:
>> 120                             Widget childComposite = Widget.class.cast(child);
>> 121                             if (!childComposite.isDisposed()) {
>> -rename variable "childComposite" -> "childWidget"?
>> 
>> IndexItemSelector.java:
>> 34     private ItemParent<? extends Item> parent;
>> -can be final
>> 
>> SWTExecutor.java:
>> -really keep the commented code?:
>> 41         /*
>> 42         if (isInAction()) {
>> 43             action.execute(parameters);
>> 44         } else {
>> 45          *
>> 46          */
>> and
>> 53         //}
>> 
>> TextItemSelector.java:
>> 35     private ItemParent<? extends Item> parent;
>> -can be final
>> 
>> ByStringQueueLookup.java
>> -remove empty javadocs (or fix)
>> 
>> /Erik 
>> 
>>> 17 jan. 2018 kl. 22:58 skrev Alexandre (Shura) Iline <alexandre.iline at oracle.com>:
>>> 
>>> Hi.
>>> 
>>> Can you please take a look on this change introducing JemmySWT into the code-tools Jemmy repository?
>>> http://cr.openjdk.java.net/~shurailine/7902099/webrev.00/
>>> 
>>> Thank you.
>>> 
>>> Shura
>>> 
>>> 
>> 
> 



More information about the jemmy-dev mailing list