Initial webrev with changes for JDK 9
Mandy Chung
mandy.chung at oracle.com
Fri Mar 11 22:22:42 UTC 2016
> On Mar 11, 2016, at 1:19 PM, Paul Sandoz <paul.sandoz at oracle.com> wrote:
>
>>
>> On 11 Mar 2016, at 21:53, Mandy Chung <mandy.chung at oracle.com> wrote:
>>
>> I agree. It's also used from ResourceBundle.Control::newBundle. Since core reflection now gets readability for free, setAccessible is no longer needed [1]. So it can call Class::newInstance instead. I fixed both places not to use Unsafe.
>>
>
> Thanks!
In fact, I have to keep setAccessible since the type may not exported to java.base. I changed it to use sneaky throw.
> Ok. One advantage of the merged-approach is it’s atomic. The former may update an entry twice if there is a race, but that may not matter.
OK. Good to change it anyway.
In case you want to see the diff:
http://cr.openjdk.java.net/~mchung/jigsaw/webrevs/jake-m3/webrev-03-11/index.html
Mandy
More information about the jigsaw-dev
mailing list