Initial webrev with changes for JDK 9
Mandy Chung
mandy.chung at oracle.com
Wed Mar 16 03:42:09 UTC 2016
Daniel,
Thanks for the review.
> On Mar 15, 2016, at 10:48 AM, Daniel Fuchs <daniel.fuchs at oracle.com> wrote:
>
>
> 120 @Override
> 121 public int hashCode() {
> 122 int hash = 7;
> 123 hash = 67*hash + Objects.hashCode(this.filename) +
> 124 Objects.hashCode(this.path);
> 125 return hash;
> 126 }
>
> I wonder if that could be simplified in:
>
> return Objects.hash(this.filename, this.path);
>
Good idea. I made the change.
>
> typo:
> 443 // otherwise analyze the depednencies
Fixed.
Mandy
More information about the jigsaw-dev
mailing list