RFR: 6588: Move JMC core to JDK 8

Marcus Hirt hirt at openjdk.java.net
Wed Jan 20 16:16:42 UTC 2021


On Wed, 20 Jan 2021 15:50:39 GMT, Jie Kang <jkang at openjdk.org> wrote:

>> @thegreystone Hi Marcus! The changes I've seen so far are to make use of JDK 8 language features where the overall functionality/result is the same. Are there any parts of the code where functionality is changed that might need a closer look?
>
>> @jiekang - this is mostly a first step to make IItemCollection and friends more streaming friendly for consumers of core. There is also an API name change getTimeRanges -> getAvailableTimeRanges (for API introduced in 8, so should be OK). I'm thinking we might be able to perhaps find a better name there. It's all of the available time ranges in the recording, not necessarily only for the filtered collection. getOriginalTimeRanges?
> 
> Original sounds fine, or maybe Unfiltered? I think the changes generally look fine otherwise.

Jaroslav had a good comment. This method is behaving differently, and perhaps it would be better to have an events.unfiltered method which returns the unfiltered collection, and have a getTimeRanges method that actually does what is expected on the collection, unfiltered or not. 

I suggest going with getUnfilteredTimeRanges() and marking it as deprecated for the 8.0.0 release.

-------------

PR: https://git.openjdk.java.net/jmc/pull/194


More information about the jmc-dev mailing list