Status of jtreg build

Carsten Varming varming at
Mon Apr 11 18:06:17 UTC 2016

Dear jtreg devs,

I wanted to download jtreg to run JDK9 hotspot regression tests, but I have
been unsuccessful so far. Perhaps you know what I need to do to get going.

The hotspot regression tests need at least jtreg 4.2 b01. When I downloaded
the latest build published at (4.2.0-tip, from build
496) and tried the hotspot regression tests I got:

Error: Unexpected exception occurred! java.lang.NumberFormatException: For
input string: "ip"
java.lang.NumberFormatException: For input string: "ip"
java.lang.NumberFormatException.forInputString(java.base at 9-internal
        at java.lang.Integer.parseInt(java.base at 9-internal/
        at java.lang.Integer.parseInt(java.base at 9-internal/
        at com.sun.javatest.regtest.Version.getBuild(
        at com.sun.javatest.regtest.Version.compareTo(
        at com.sun.javatest.regtest.Main.main(

I suspect the check against "requiredVersion=4.2 b01" from TEST.ROOT (
went wrong. I suspect "build = manifest.getProperty("jtreg-Build");" in
sets to "tip" and Version.getBuild tries to parse "ip" as a
number. :(

I tried to get past this problem by changing the required jtreg version to
4.1 b01. That gets the tests running, but a third of them fail with a class
loading problem: A ClassFormatError is thrown with "Truncated class file".
This seems to be due to a
missing java/lang/reflect/JTRegModuleHelper.class. I suspect that this
requirement was introduced with the module system that was integrated a few
weeks ago.

So, how do I get a version of jtreg that works with the latest JDK9?

BTW. It looks like the jtreg build ( is failing because of a
missing dependency on testng.

Help much appreaciated,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the jtreg-use mailing list