Status of jtreg build

Jonathan Gibbons jonathan.gibbons at
Tue Apr 12 21:11:38 UTC 2016

On 04/11/2016 11:06 AM, Carsten Varming wrote:
> Dear jtreg devs,
> I wanted to download jtreg to run JDK9 hotspot regression tests, but I 
> have been unsuccessful so far. Perhaps you know what I need to do to 
> get going.
> The hotspot regression tests need at least jtreg 4.2 b01. When I 
> downloaded the latest build published at 
> (4.2.0-tip, from 
> build 496) and tried the hotspot regression tests I got:
> Error: Unexpected exception occurred! java.lang.NumberFormatException: 
> For input string: "ip"
> java.lang.NumberFormatException: For input string: "ip"
>         at 
> java.lang.NumberFormatException.forInputString(java.base at 9-internal/
>         at 
> java.lang.Integer.parseInt(java.base at 9-internal/
>         at 
> java.lang.Integer.parseInt(java.base at 9-internal/
>         at com.sun.javatest.regtest.Version.getBuild(
>         at com.sun.javatest.regtest.Version.compareTo(
>         at
>         at
>         at com.sun.javatest.regtest.Main.main(
> I suspect the check against "requiredVersion=4.2 b01" from TEST.ROOT 
> ( 
> went wrong. I suspect "build = manifest.getProperty("jtreg-Build");" 
> in 
> sets to "tip" and Version.getBuild tries to parse "ip" 
> as a number. :(
> I tried to get past this problem by changing the required jtreg 
> version to 4.1 b01. That gets the tests running, but a third of them 
> fail with a class loading problem: A ClassFormatError is thrown with 
> "Truncated class file". This seems to be due to a 
> missing java/lang/reflect/JTRegModuleHelper.class. I suspect that this 
> requirement was introduced with the module system that was integrated 
> a few weeks ago.
> So, how do I get a version of jtreg that works with the latest JDK9?
> BTW. It looks like the jtreg build 
> ( is failing because 
> of a missing dependency on testng.
> Help much appreaciated,
> Carsten

The version of jtreg available on has the following entry 

     jtreg-Build: tip

and jtreg is naively assuming it to be of the form
     jtreg-Build: b<integer>

I can make jtreg be more tolerant, but I also also note that the binary 
is missing lib/asmtools.jar, which is required by some tests.  The 
contents of the tar bundle are all dated 25 January 2016, 10:47 which is 
somewhat suspicious.

-- Jon

More information about the jtreg-use mailing list