jtreg 4.2-b02 -agentvm + jdk-9+118 = FAIL

Martin Buchholz martinrb at google.com
Fri May 13 19:04:48 UTC 2016

I tried updating jsr166 to jdk-9+118 today, but there's a snag - jtreg
won't start.
A simple repro is:

jtreg -agentvm -testjdk:/home/martin/jdk/jdk-9-ea+118 .
Agent[0].stdout: Bad value for -Xpatch, no module name specified
Agent[0].stderr: Error: Could not create the Java Virtual Machine.
Agent[0].stderr: Error: A fatal exception has occurred. Program will exit.

It looks like jtreg is synthesizing an -Xpatch flag, but the syntax of
that has changed.

strace shows the flag

Jonathan has been making -Xpatch related changes to jtreg in mercurial
that may have already fixed it, but if so, making a 4.2-b03 release is
urgent.  It would be nice if there were one jtreg binary that could
work with any jdk9 build, but that's understandably difficult.

Of course, jsr166 wants to add its own -Xpatch flags; hopefully that
will be able to peacefully coexist with whatever jtreg ends up doing.

More information about the jtreg-use mailing list