jtreg 4.2-b02 -agentvm + jdk-9+118 = FAIL

Martin Buchholz martinrb at google.com
Fri May 13 19:29:16 UTC 2016

On Fri, May 13, 2016 at 12:18 PM, Alan Bateman <Alan.Bateman at oracle.com> wrote:
> On 13/05/2016 20:04, Martin Buchholz wrote:
>> I tried updating jsr166 to jdk-9+118 today, but there's a snag - jtreg
>> won't start.
>> A simple repro is:
>> jtreg -agentvm -testjdk:/home/martin/jdk/jdk-9-ea+118 .
>> Agent[0].stdout: Bad value for -Xpatch, no module name specified
>> Agent[0].stderr: Error: Could not create the Java Virtual Machine.
>> Agent[0].stderr: Error: A fatal exception has occurred. Program will exit.
>> It looks like jtreg is synthesizing an -Xpatch flag, but the syntax of
>> that has changed.
>> strace shows the flag
>>   "-Xpatch:/home/martin/jsr166/Xpatch/src/test/jtreg/JTwork/patches"
>> Jonathan has been making -Xpatch related changes to jtreg in mercurial
>> that may have already fixed it, but if so, making a 4.2-b03 release is
>> urgent.  It would be nice if there were one jtreg binary that could
>> work with any jdk9 build, but that's understandably difficult.
>> Of course, jsr166 wants to add its own -Xpatch flags; hopefully that
>> will be able to peacefully coexist with whatever jtreg ends up doing.
> We transitioned to the new form of -Xpatch in jdk-9+118.
> jtreg 4.2 b02 can use the old or new form. It's configured via the
> useNewXpatch property in the test suite configuration. In jdk-9+118 then
> each test root had its TEST.ROOT changed to include useNewXpatch=true so
> that jtreg uses the new form of -Xpatch.

Thanks!  That explains why I can still run jtreg -agentvm on openjdk itself.
(But useNewXpatch feels wrong because it's not a property of the test
suite itself, but of the testjdk ...)

> For jtreg 4.2 b03 then Jon has removed support for the old form of -Xpatch.
> I don't think you need that just yet.

I'll probably wait for 4.2-b03.

More information about the jtreg-use mailing list