Problem with vmoptions versus javaoptions

Martin Buchholz martinrb at
Mon Jun 25 16:55:47 UTC 2018

Hi David,

I tried adding
 '-javaoptions:-XX:+UnlockExperimentalVMOptions -XX:+UseJVMCICompiler
to my jtreg invocation, and it worked!  I can tell something changed
because my test (FJExceptionTableLeak!) ran much more slowly!
I suspect shell quoting misstep.

On Sun, Jun 24, 2018 at 4:32 PM, David Holmes <david.holmes at>

> If I pass:
> -vmoptions:"-XX:+UnlockExperimentalVMOptions -XX:+UseJVMCICompiler -Xcomp"
> the tests run fine but take excruciatingly long as the compilations are
> also running in Xcomp mode. So I tried changing to -javaoptions and got:
> Error: VM option 'UseJVMCICompiler' is experimental and must be enabled
> via -XX:+UnlockExperimentalVMOptions.
> Error: The unlock option must precede 'UseJVMCICompiler'.
> Error: Could not create the Java Virtual Machine.
> Error: A fatal exception has occurred. Program will exit.
> It's like the options were not being parsed and passed correctly.
> Any ideas?
> Thanks,
> David
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the jtreg-use mailing list