Starting tests for jkd/tools/jlink

Oliver Kopp at
Wed Oct 19 12:10:16 UTC 2022


I tried to follow the instructions at
to run a test.

I tried to execute the following statement:

make test TEST="jtreg:test/jdk/tools

The result is as follows (excerpt)

Building target 'test' in configuration 'windows-x86_64-server-release'
Test selection 'jtreg:test/jdk/tools
test/jdk/tools/jlink/', will run:
* jtreg:test/jdk/tools
* jtreg:test/jdk/tools/jlink/

Running test 'jtreg:test/jdk/tools'
Error occurred during initialization of boot layer
java.lang.NullPointerException: Cannot invoke
"java.lang.Iterable.iterator()" because "enums" is null
Error: Compilation of extra property definition files failed. rc=1
Finished running test 'jtreg:test/jdk/tools'
Test report is stored in

Is there a previous make target missing I should execute?

I am running on Windows 10 and have configured the jdk as follows:

./configure --with-boot-jdk=/cygdrive/c/Program\ Files/OpenJDK/jdk-19/


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the jtreg-use mailing list