hg: kulla/dev/langtools: API overhaul snippet->key, step 3: new API in place, alongside old.

robert.field at oracle.com robert.field at oracle.com
Tue Apr 21 06:18:13 UTC 2015


Changeset: e84aa9e12a31
Author:    rfield
Date:      2015-04-20 23:18 -0700
URL:       http://hg.openjdk.java.net/kulla/dev/langtools/rev/e84aa9e12a31

API overhaul snippet->key, step 3: new API in place, alongside old.
All that remains to be done to the API:
1. Remove SnippetInfo and nested interfaces
2. Remove EvalState.*DEPRECATED()
3. Remove EvalResult.info
4. Rename Key.keykind() to Key.kind()
Tests need to remove all uses of SnippetInfo and its subclasses.
Tests need to use EvalState.*() instead EvalState.*DEPRECATED().
Repl needs to do the same, I will do this.
The rename will happen later after SnippetInfo (which conflicts) is gone.

! repl/src/api/EvalState.java
! repl/src/api/Key.java
! repl/src/api/SnippetInfo.java
! repl/src/impl/EvalStateImpl.java
! repl/src/impl/SnippetImpl.java
! repl/src/impl/SnippetMaps.java
! repl/src/tool/Repl.java
! repl/testng/stress/DeclareStressTest.java
! repl/testng/test/ClassesTest.java
! repl/testng/test/KullaTesting.java
! repl/testng/test/ReplaceTest.java
! repl/testng/test/SimpleRegressionTest.java
! repl/testng/test/SnippetTest.java
! repl/testng/test/TypeNameTest.java
! repl/testng/test/VariablesTest.java



More information about the kulla-dev mailing list