let's play TDD, tackles closures in java

Llewellyn Falco isidore at setgame.com
Wed Dec 15 11:04:05 PST 2010


actually, i don't understand the choice

model.addTableModelListener(#{e -> fired = true});
>

over

model.addTableModelListener(e => fired = true);

if you don't want to be like c# you could always go with simply

model.addTableModelListener(e -> fired = true);

I know there's  an attitude of  "we need to finalize the spec as java8 is
around the corner, and it's too late to change anything". But this seems to
be an odd choice for the readability enhancement.

Llewellyn Falco


More information about the lambda-dev mailing list