Review Request: 8004201: add reducers to primitive type wrappers
Stephen Colebourne
scolebourne at joda.org
Wed Dec 5 15:02:25 PST 2012
Which would lead me to look at
http://docs.oracle.com/javase/tutorial/java/nutsandbolts/opsummary.html
and wonder about increment/decrement/shifts etc.... :-)
Also noting that Integer.rotateLeft() and friends exist, so the shifts
might well fit there.
Stephen
On 5 December 2012 22:53, Brian Goetz <brian.goetz at oracle.com> wrote:
> Here, we're adding things that could be converted to SAMs, and logicalNot
> could be converted to a UnaryOperator, so, there's a case :)
>
>
> On 12/5/2012 5:26 PM, Stephen Colebourne wrote:
>>
>> On 5 December 2012 21:27, Akhil Arora <akhil.arora at oracle.com> wrote:
>>>
>>> Updated - http://cr.openjdk.java.net/~akhil/8004201.1/webrev/
>>>
>>> - delegate to Math.min/max for int/long/float/double
>>> - rename Boolean.and/or/xor to logicalAnd/logicalOr/logicalXor
>>
>>
>> Is there a case for logicalNot() ?
>>
>> Stephen
>>
>
More information about the lambda-dev
mailing list