On 01/03/13 14:18, Brian Goetz wrote: >> Why not be plainer about it and use FromIntFunction. >> People will catch on that the other one, IntFunction means ToIntFunction. > OK, forget I said the second part about generalizing this. I still think "FromIntFunction" is less cringe-y than hiding the "T" in the middle of "IntTFunction" :-) -Doug