One more pass on flatMap/mapMulti

Tim Peierls tim at peierls.net
Thu Jan 10 09:28:02 PST 2013


On Thu, Jan 10, 2013 at 11:59 AM, Brian Goetz <brian.goetz at oracle.com>wrote:

> Bikeshed discussions can continue.


OK, then! :-)

The method name "send" is OK, but you wouldn't be seeing it in the
signature of explode. What you would see is Downstream<T>, which still bugs
me. The word "downstream" is an adverb or adjective, not a noun. Things are
sent downstream, they aren't sent *to* a downstream.

Was Acceptor.accept proposed and rejected already? If so, why? I would
understand

  explode(BiBlock<Acceptor<T>**, T>))

--tim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/lambda-libs-spec-experts/attachments/20130110/09f6a6c4/attachment.html 


More information about the lambda-libs-spec-experts mailing list