Let's please rename Block to Receiver before it's too late

Tim Peierls tim at peierls.net
Fri Jan 18 14:26:05 PST 2013


On Fri, Jan 18, 2013 at 5:08 PM, Raab, Donald <Donald.Raab at gs.com> wrote:

> This ex-Smalltalker still prefers Procedure.
>

And this non-Smalltalker prefers Procedure, Receiver, Handler ... pretty
much anything except Block, which is an inert chunk of wood to me.


Please can we rename collect as well.


Whoa, steady -- I *like* collect. I see the overlap issue, but that really
can't be allowed to stand in the way of a good name. What were you
proposing instead?

--tim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/lambda-libs-spec-experts/attachments/20130118/a18d3bc6/attachment.html 


More information about the lambda-libs-spec-experts mailing list