Let's please rename Block to Receiver before it's too late

Kevin Bourrillion kevinb at google.com
Fri Jan 18 15:28:52 PST 2013


On Fri, Jan 18, 2013 at 2:56 PM, Joe Bowbeer <joe.bowbeer at gmail.com> wrote:

I prefer Procedure to Receiver, but I'm getting used to Block despite my
> initial exasperation.  At the moment, I prefer Block to Receiver.
>
> Procedure > Block > Receiver
>
> Receiver is commonly used in Android (BroadcastReceiver) and is a common
> name in message and event frameworks, as is Handler, so I consider them
> both out-of-bounds for use here.
>

Finally we have what seems to be the first concrete complaint about
Receiver here.  Thank you.  So we can list that as a strike against it.  I
see no reason that makes it an automatic DQ.

Procedure seems to have a lot of support, but again, very little concrete
explanation of *why*.  If it's "that's what X calls it," that's worth *
something*, but how *much* it's worth is at least partly dependent on just
how many Java programmers today actually know anything about X.

As I've expressed, I see tremendous value in this name ("IntReceiver" or
"IntConsumer", etc.) painting* that* clear and obvious a picture of what
the thing is. Just as IntSupplier does. It seems that others here really
just don't see that value? If that's so, then okay, I'm done here. Just
surprised.


-- 
Kevin Bourrillion | Java Librarian | Google, Inc. | kevinb at google.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.openjdk.java.net/pipermail/lambda-libs-spec-experts/attachments/20130118/3644f0d5/attachment-0001.html 


More information about the lambda-libs-spec-experts mailing list